amavis-stats läuft nicht mehr unter Debian 4.0 (etch)

Nach einem Update von Debian 3.1 (sage) auf Debian 4.0 (etch) habe ich festgestellt, dass amavis-stats nicht mehr läuft. Wenn man die Webseite von amavis-stats aufruft erscheint die Fehlermeldung: „amavis-stats::error: rrd_graph(): 1“.

Nach einer Recherche im Internet habe ich im Blog www.linuri.de entdeckt (Update leider gibt es diesen Blog inzwischen nicht mehr und deshalb habe ich den Link entfernt), dass amavis-stats nicht mit der neuen Version 1.2.15-0.3 des rrdtools zurecht kommt. Der Bug scheint bei Debian am 18. April unter der Nummer #419874 auch schon gemeldet worden zu sein. Eine Lösung – außer dem Downgrade auf die alte Version 1.0.49-1 des rrdtools aus Debian 3.1 (sage) – scheint es z.Zt. jedoch noch nicht zu geben.

Update:
Inzwischen ist bei Debian eine einfache Lösung für den Bug #419874 zu finden. Man muss dazu lediglich zwei Zeilen Code in der Datei /usr/share/amavis-stats/amavis-stats.php ändern. Es sollte also auch bald ein korrigiertes Softwarepaket geben.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.