Powerbank für Notebooks mit USB-C

Da ich viel unterwegs bin, hatten meine Notebooks schon immer sehr leistungsstarke Akkus. Dennoch kam es immer wieder vor, dass mir unterwegs der Strom ausging. Bei meinem iPad und iPhone konnte dann immer eine Powerbank aushelfen. Für das laden des Notebooks reichte die Leistung des Stroms von USB-A jedoch nicht aus.

Inzwischen gibt es neuere Powerbanks mit USB-C Anschlüssen. Bei USB-C gibt es das Feature „USB Power Delivery“. Wenn die Powerbank diese Feature unterstützt, kann das Angeschlossene Gerät eine Ladung mit einer Leistung von bis zu 100 Watt aushandeln. Diese Leistung langt dann auch für Notebooks.

Ich habe seit kurzem ein Apple MacBook Pro mit 15“, dass über USB-C geladen wir. Deshalb konnte ich es kaum erwarten das laden des Notebooks über eine Powerbank zu testen. Ein Recherche im Internet ergab, dass bei leibe nicht alle USB-C Powerbanks das Feature „USB Power Delivery“ unterstützen. Zudem konnte ich kaum eine Powerbank finden, die eine Leistung von 100 Watt bereitstellen konnte. Und wenn eine Powerbank 100 Watt konnte, war sie sehr groß und teuer.

Meine Entscheidung

Schlussendlich habe ich mich für die „Xlayer Powerbank PLUS MacBook
20100″ entschieden. Diese hat ein moderates Preis-Leistungs-Verhältnis und kann über „USB Power Delivery“  immerhin 45 Watt für ein Gerät zum laden bereit stellen. Dabei kann die Powerbank eine Leistung von 20100 mAh bei 3,6 Volt erbringen und kommt damit auf eine Kapazität von 72.4 Wh. Somit hat sie eine Kapazität von unter 100 Wh und darf mit in Flugzeuge genommen werden. Eine Eigenschaft die für mich sehr wichtig ist.

Technische Details:

  • Abmessung: 172 x 66 x 23(L x W x H)
  • Kapazität: 72.4 Wh (3.6V/20100 mAh)
  • Eingang: Type C: 5V/3A, 9V/2A, 12V/2A, 14.5V/1.5A, 20V/1.5A
  • Ausgang: 2 x Type A: (5V/2,4A); Type C: 5V/3A, 9V/3A, 12V/3A, 14.5V/3A, 20V/2.25A
  • Akku-Typ: Lithium Polymer
  • Gewicht: 460 g
  • Display: LED-Batterie-Ladestandanzeigen
  • Anschlüsse: Type C (Eingang / Ausgang), 2 x USB-A (Ausgang)

Wie ist die Powerbank im Täglichen Einsatz?

Mich überzeugt die Powerbank durch ihr schickes Design und die hochwertige Verarbeitung bei einem guten Preis-Leistung-Verhältnis. Somit kann ich die Powerbank rundum empfehlen. Sie ist in der Lage meinen MacBook Pro 15“ 2017 auf eine Ladung von ca. 75% zu bringen. Das entspricht bei meiner typischen Arbeit einer Laufzeitverlängerung von ungefähr 7-8 Stunden. Mein iPad und iPhone konnte ich mit der Powerbank sogar fast drei Tage betreiben, ohne eine Steckdose zu benötigen. Somit ist die Powerbank in der Lage mich ca. einen ganzen Tag mit Strom für meine Mobilgeräte zu versorgen und ermöglicht mir somit wesentlich mehr Unabhängigkeit von Steckdosen.

Wo gibt es die Powerbank zu kaufen?

Falls Euch der Artikel gefallen habt und die Powerbank kaufen möchtet, könnt Ihr das über den folgenden Link zu Amazon machen. Es handelt sich dabei um einen Affiliate-Link und Ihr unterstütz mich damit.

Vielen Dateien eine andere Dateiendung geben

Ab und zu hat man bei der Administration die Aufgabenstellung vielen Datei eine andere Dateiendung zu geben. Hier eine kleine Programmzeile, mit der man diese Aufgabe sehr erleichtern kann. Mit dieser kann man unter Linux oder MacOSX an alle Dateien in einem Verzeichnis die Dateiendung „.pdf“ anhängen.

ls * | cat | while read n; do mv "$n" "$n.pdf"; done

Mehrere E-Mail-Adressen für einen Account bei Apple Mail benutzen

Ich musste heute etwas suchen, um herauszufinden, wie man bei Apple Mail mehrere E-Mail-Adressen für einen Account einstellen kann. Das ist nämlich so einfach, dass man nicht gleich drauf kommt. Und laut Google haben lustiger Weise viele das Problem.

Die Lösung ist: Man trägt einfach alle E-Mail-Adressen kommasepariert bei den Account-Informationen im Feld E-Mail-Adresse ein. Anschliessend kann man diese E-Mail-Adressen beim Verfassen über das Drop-Down Accounts auswählen, bzw. Mail wählt selbständig beim Antworten die korrekte Alias-Adresse aus.

Excel 2011 kann 500.000 Zeilen

Excel 500tWie ich gerade feststelle, kann man in Excel 2011 von Microsoft selbst bei fast einer halben Million Zeilen noch mit Pivot-Tabellen arbeiten. Ich habe so etwas in Excel schon länger nicht mehr probiert und hatte auch keine große Hoffnung das es klappt. Bei den älteren Excel-Versionen war schon bei 32.000 Zeilen bzw. bei 64.000 Zeilen Schluss. Da hätte ich jetzt erwartet das es bis vielleicht bis 128.000 oder 254.000 geht.

Alleine die Datei ist schon 100 MB groß und das öffnen der selben dauert auf meinem super schnelle Computer (core 7i mit SSD und 8 GB RAM) fast eine Minute. Aber wenn die Datei geladen ist kann man halbwegs damit arbeiten.

Mac OS X: Synchronisierung mit einem Exchange-Server

Im Gegensatz zu Microsoft, die E-Mails, Termine und Kontakte in Outlook bündeln, liefert Apple bei Mac OS X dafür die drei Programme Mail, iCal und Adressbuch aus. Um die Funktionalitäten von Outlook auf einem Apple zu nutzen muss man also diese drei Programme verwenden.

Wenn man in Microsoft-Umgebungen Outlook für Kollaboration (Gruppenterminplanung, Ressourcenplanung, Dokumentenfreigabe usw.) verwenden möchte hat Microsoft dafür den Exchange-Server im Angebot. Apple hat bis jetzt keine entsprechende Software im Sortiment. Ab Mac OS X „Snow Leopard“ liefert Apple aber einen sogenannten „Out-of-the-box Support“ für Microsoft Exchange mit. Dabei ist jedoch zu beachten, dass Apple dafür ein „Microsoft Exchange Server 2007 Service Pack 1 Update Rollup 4“ erwartet. Bei einem Exchange 2003 lief bei mir nur Mail. iCal und das Adressbuch funktionierten nicht.

Im folgenden nun eine kleine Anleitung für die Einrichtung eines Mac OS X „Snow Leopard“ für die Zusammenarbeit mit einem Exchange 2007. Exchange 2010 habe ich bis jetzt noch nicht getestet, werde dies aber demnächst nachholen.

Mail
Mail nutzt das IMAP- und SMTP-Protokoll sowie die OWA-Schnittstelle (Outlook Web Access). Die Voraussetzung für die Verwendung von Mail ist also, dass diese Protokolle und Dienste auf dem Exchange-Server richtig eingerichtet wurden und erreichbar sind. Wenn dies gegeben ist kann man Mail mit drei Schritten über den Dialog zum einrichten neuer Accounts einrichten. Wenn man Mail das erste mal öffnet, startet dieser automatisch. Wenn der Benutzername „tester“ und der IMAP-, SMTP- und OWA-Server „mail.appletest.de“ heißen, sieht dies wie folgt aus:

iCal
Wenn Mail für die Verwendung eines Exchange-Server konfiguriert ist, sollte auch iCal auf den Exchange-Server zugreifen können. Um den Kalender angezeigt zu bekommen, muss man nur noch iCal starten und den Kalender über „Ablage“ > „Name des Exchange Accounts bei Mail“ öffnen.

Adressbuch

  • Das Programm „Adressbuch“ öffnen und „Adressbuch“ > „Einstellungen“ wählen.
  • Im Bereich „Allgemein“ die Option „Mit Exchange-Server synchronisieren“ auswählen und und auf „Konfigurieren“ klicken (falls erforderlich).
  • Exchange Benutzernamen, das Kennwort und die OWA Server-Adresse eingeben.
  • „Stündlich synchronisieren“ wählen, wenn die Daten im Stundentakt synchronisiert werden sollen.

iTunes konnte sich nicht mit dem iPhone verbinden: 0xE8000035

iTunes kann sich nicht mit einem iPhone oder einem iPod verbinden, wenn der Buffer für den USB-Anschluss zu groß ist. iTunes meldet dann den Fehler 0xE8000035. Insbesondere bei Virtuellen Maschinen unter VM-Ware oder VirtualBox scheint dieses Problem öfter aufzutreten. Bei VM-Ware ist dieses Problem bei der neusten Version bereits behoben und bei VirtualBox soll es ab der Version 2.1 gelöst sein.

Wenn die Virtuelle Maschine unter Linux läuft kann man das Problem auch lösen, indem man in den Kernel-Sourcen in der Datei drivers/usb/core/devio.c die MAX_USBFS_BUFFER_SIZE auf 131072 reduziert.

Wie das unter Ubuntu geht ist in dem Blog www.huanix.com sehr ausführlich beschrieben.

Cisco ASA Konfiguration für das iPhone

Ab der Softwareversion 2.0 kann das Apple iPhone nicht nur L2PT und PPTP sondern auch richtige IPSec Verbindungen zu Firewalls von CISCO (z.B. PIX oder ASA) aufbauen. Leiter konnte ich auf den Webseiten von Apple und Cisco nur die Information finden, dass es funktionieren soll. Eine Anleitung oder ein HowTo für die Konfiguration der PIX oder ASA konnte ich nicht finden. Deshalb habe ich selber herumprobiert und die folgende Konfiguration auf einer Cisco ASA 5505 mit einem iPhone 3G (Softwareversion 2.1) zu laufen gebracht:

Cisco ASA Konfiguration für das iPhone

ASA Version 7.2(4) 
!
hostname minastirith
domain-name domain.de
enable password testpasswort
passwd testpasswort
names
name 172.20.20.0 LAN
name 172.20.52.0 iPhones
!
interface Vlan1
 nameif LAN
 security-level 100
 ip address 172.20.20.1 255.255.255.0 
!
interface Vlan2
 nameif INTERNET
 security-level 0
 ip address 217.6.26.94 255.255.255.248 
!
interface Ethernet0/0
 switchport access vlan 2
!             
interface Ethernet0/1
!
interface Ethernet0/2
 shutdown
!
interface Ethernet0/3
 shutdown
!
interface Ethernet0/4
 shutdown
!
interface Ethernet0/5
 shutdown
!
interface Ethernet0/6
 shutdown
!
interface Ethernet0/7
 shutdown
!
ftp mode passive
clock timezone MET 1
dns server-group DefaultDNS
 domain-name domain.de
access-list INTERNET_access_in extended permit ip iPhones 255.255.255.0 LAN 255.255.255.0 
access-list iPhone_splitTunnelAcl standard permit LAN 255.255.255.0 
access-list inside_outbound_nat0_acl extended permit ip LAN 255.255.255.0 iPhones 255.255.255.0 
pager lines 24
logging enable
logging asdm informational
mtu LAN 1500
mtu INTERNET 1500
ip local pool iphone_pool 172.20.52.101-172.20.52.199
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (INTERNET) 1 interface
nat (LAN) 0 access-list inside_outbound_nat0_acl
nat (LAN) 1 0.0.0.0 0.0.0.0
access-group INTERNET_access_in in interface INTERNET
route INTERNET 0.0.0.0 0.0.0.0 217.6.26.89 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication serial console LOCAL 
aaa authentication ssh console LOCAL 
aaa authentication http console LOCAL 
http server enable
http LAN 255.255.255.255 LAN
http LAN 255.255.255.0 LAN
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto dynamic-map INTERNET_dyn_map 20 set pfs 
crypto dynamic-map INTERNET_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map INTERNET_dyn_map 40 set pfs 
crypto dynamic-map INTERNET_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic INTERNET_dyn_map
crypto map outside_map interface INTERNET
crypto isakmp enable INTERNET
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 65535
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh LAN 255.255.255.255 LAN
ssh timeout 60
console timeout 0

group-policy iPhone internal
group-policy iPhone attributes
 wins-server value 172.20.20.21
 dns-server value 172.20.20.21
 vpn-tunnel-protocol IPSec 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value iPhone_splitTunnelAcl
 default-domain value domain.de
username admin password testpasswort privilege 15
username marco password testpasswort privilege 0
username marco attributes
 vpn-group-policy iPhone
tunnel-group VPN-Clients type ipsec-ra
tunnel-group iPhone type ipsec-ra
tunnel-group iPhone general-attributes
 address-pool iphone_pool
 default-group-policy iPhone
tunnel-group iPhone ipsec-attributes
 pre-shared-key testkey
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect netbios 
  inspect rsh 
  inspect rtsp 
  inspect skinny 
  inspect esmtp 
  inspect sqlnet 
  inspect sunrpc 
  inspect tftp 
  inspect sip 
  inspect xdmcp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:d41d8cd98f00b204e9800998ecf8427e
: end