VPN-Anbindung eines Ubuntu an eine FRITZ!Box

Einige Fritzboxen können IPSec. Um dies für den Fernzugriff auf das Netzwerk hinter der Fritzbox nutzen zu können bietet AVM sogar einen einfach zu handhabenden IPSec-Client an. Diesen gibt es aber leider bis jetzt nur für Windows. Natürlich kann man auch von Ubuntu eine IPSec Verbindung zu einer Fritzbox aufbauen. Dazu benötigt man aber einen IPSec-Client. Am einfachsten ist es, wenn man hierzu den „Shrew Soft VPN Client“ verwendet, da dieser bei Ubuntu bereits als Paket im universe-Netzwerk bereit steht und einfach mit apt-get install ike installiert werden kann.

Eine sehr genaue Anleitung für die Konfiguration der Fritzbox und die Konfiguration des Clients findet man auf der Webseite von AVM.

Bei mir funktionierte die VPN-Verbindung allerdings erst, nachdem ich den rp-filter ausgeschaltet hatte. Dies erreicht man bei Ubuntu, indem man in den Dateien /etc/sysctl.conf und /etc/sysctl.d/10-network-security.conf die Zeilen rp_filter=1 in rp_filter=0 ändert und das System neu startet.

Weitere Informationen findet man im Wiki der Ubuntu-User unter: http://wiki.ubuntuusers.de/FritzBox_VPN

Stromverbrauch bei Switchen mit 8 Ports

Gerade bei Switchen spielt der Stromverbrauch eine entscheidende Rolle, da sie normaler Weise rund um die Uhr laufen. Bei kleinen Switchen können die Kosten des jährlichen Stromverbrauchs die Kosten der Anschaffung schnell übersteigen. Aus diesem Grund habe ich den Stromverbrauch von einigen gängigen Switchen mit 8 Ports ermittelt.

Hersteller Model Verbrauch (Ohne angeschlossene PCs)
3Com OfficeConnect Dual Speed Hub 8 (8 Ports) 9,4 W
Allnet ALL8445 Ver.B1 (5 Ports) 2,6 W
Netgear FS108 v2 (8 Ports) 1,5 W
Linksys (Cisco) (8 Ports) W

Cisco Aironet 1242AG AccessPoint als WLAN Bridge

Im folgenden die Konfiguration für einen Cisco Aironet 1242AG AccessPoint, der als WLAN Bridge für ein kleines Netzwerk eingerichtet wurde. Das lokale Netzwerk hat das IP-Netz 192.168.1.0/24. Das Gateway und der DNS-Server haben die IP-Adresse 192.168.1.1 und der Accesspoint selber hat die IP-Adresse 192.168.1.2. Der Accesspoint fungiert zudem als DHCP-Server und verteilt dynamischen IP-Adressen im Bereich von 192.168.1.101 bis 192.168.1.199.



!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname accesspoint
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local 
!
aaa session-id common
!
resource policy
!
ip subnet-zero
ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.100
ip dhcp excluded-address 192.168.1.200 192.168.1.254
!
ip dhcp pool LAN
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1 
   dns-server 192.168.1.1 
!
!
!
dot11 ssid WLAN
   authentication open 
   authentication key-management wpa
   wpa-psk ascii geheimespasswort
!         
power inline negotiation prestandard source
!
!
username admin privilege 15 password geheimespasswort
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers tkip 
 !
 ssid WLAN
 !
 station-role root
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 shutdown
 no dfs band block
 channel dfs
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 no cdp enable
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 192.168.1.2 255.255.255.0
 no ip route-cache
!
ip http server
ip http authentication aaa
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
!
end

Klonen ohne Norton Ghost

Fast jeder kennt das Programm Norton Ghost® als ultimatives Programm zum klonen von PC’s. Inzwischen gibt es aber auch Clonezilla als alternatives OpenSource Programm auf Linuxbasis. Cloenzilla basiert auf den OpenSource Programmen DRBL, Partition Image, ntfsclone, partclone und udpcast. Es kann inzwischen mit den Dateisystemen ext2, ext3, ext4, reiserfs, xfs, jfs of GNU/Linux, FAT, NTFS, und HFS+ umgehen und unterstützt in der Clonezilla SE (Server Edition) sogar das simultane klonen von mehreren PC’s.

Bau einer günstigen und leistungsfähigen Firewall

* Update: Nachdem es IPCop inzwischen nicht mehr gibt, wurde der Artikel inzwischen überarbeitet und IPCop wurde in IPFire geändert. Die Software IPFire ist aus IPCop entstanden und seit dem sogar noch wesentlich weiter entwickelt und verbessert worden. *

Wenn einem die Möglichkeiten und die Geschwindigkeit einer Fritzbox von AVM nicht mehr ausreicht und eine Kommerzielle Firewall zu teuer ist gibt es ein Alternative. Mit Hilfe der kostenlosen Firewall- und Routersoftware IPFire und einer geeigneten Hardwareplattform kann man sich für unter 300,- € eine Firewall bauen, die deutlich mehr Geschwindigkeit und Konfigurationsmöglichkeiten als eine Fritzbox bietet. Im folgenden eine kleine Anleitung für den Bau einer IPFire Firewall für 256,55- €.

Hardware
Bei der Hardwareplattform habe ich mich für ein Asus M4A78-EM Mainborad mit AMD 780G Chipsatz (Sockel AM2, AM2+ und AM3), AMD Athlon 64 X2 5200+ (EE/65W) und 1 GB DDR2 RAM entschieden. Der 780G Chipsatz zeichnet sich durch ein sehr gutes Preis-Leistung-Verhältnis aus. Er bringt eine sehr Leistungsfähige Onboard-Grafikkarte (Radeon HD3200) sowie diverse Schnittstellen mit. Auf dem M4A78-EM µATX-Mainboard von Asus sind diverse Anschlüsse und Schnittstellen zu finden (LAN, IDE, Serial ATA/300, DVI/HDMI/VGA und USB 2.0), sodass nur noch weitere Netzwerkkarten benötigt werden. Im betrieb verbraucht ein IPFire auf dieser Hardwareplattform ca. 63 Watt.

Hier die komplette Liste der von mir verwendeten Hardware:

Hardwarekomponente Produktname Preis
Mainboard ASUS M4A78-EM (AM2+, 4xDDR2, VGA, M-ATX) 64,90- €
CPU CPU Box AMD Athlon 64 X2 5200+ AM2 2,7GHz EE/65W 59,90- €
RAM Kingston DDR-2 CL5 1024MB 800MHz 16,95- €
Netzwerkkarte LevelOne FNC-0109TX 10/100 Mbps (Realtek-Chip) 4,90- €
Festplatte Samsung EcoGreen F2 500GB SATA II (HD502HI) 55,00- €
Gehäuse Minitower Jersey ZYK-Micro ATX mit 400W Netzteil 54,90- €

Software
Die jeweils aktuelle Version von IPFire kann in Form eines ISO-Images auf der Webseite https://www.ipfire.org/ herunter geladen werden und dort ist auch eine genaue Installationsanleitung zu finden.